Common Problems installing Service Fabric locally

...

Since Service Fabric released a few updates to their SDK user have frequently seen problems that local cluster won't start. Sometimes it will just fail, and sometimes take a lot of time, start and hang. Here are a few workaround you can try to resolve this situation.

Service Fabric cluster starts

But takes a long time, and start failing after a few minutes. This is a known issue, frequently related to permissions. I'm not quite sure why this happens, but it happens often for old users which keep upgrading Service Fabric SDK from a very old version (year or so) and sometimes new users.

In order to fix it, simply navigate to c:\ProgramData\Microsoft\Crypto\RSA and check that MachineKeys folder has granted full permissions to NETWORK SERVICE user. If you don't have them set, you probably have the issue.

Nothing helps

There is an issue in container support in some SDKs of Service Fabric. If you're not using containers and nothing helps, you can try this fix:

  • Open PowerShell in Administrator mode and navigate to C:\Program Files\Microsoft SDKs\Service Fabric\ClusterSetup
  • Run CleanCluster.ps1 script and patiently wait for it to clean up the cluster.
  • Check c:\sfdevcluster folder if it exists. Delete it manually if so.
  • Go deeper into C:\Program Files\Microsoft SDKs\Service Fabric\ClusterSetup\NonSecure\OneNode and edit ClusterManifestTemplate.json. Add the following section to this file:

  • Again in admin mode go to C:\Program Files\Microsoft SDKs\Service Fabric\ClusterSetup and set up a new cluster manually by typing .\DevClusterSetup.ps1 -CreateOneNodeCluster.

One this all is done, you cluster should be up. If not, please comment below and i'll try to help.


Thanks for reading. If you would like to follow up with future posts please subscribe to our rss feed.